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Preface

NOTICE TO CUSTOMERS

All documentation becomes dated, and this manual is no exception. Microchip tools and
documentation are constantly evolving to meet customer needs, so some actual dialogs
and/or tool descriptions may differ from those in this document. Please refer to our web site
(www.microchip.com) to obtain the latest documentation available.

Documents are identified with a “DS” number. This number is located on the bottom of each
page, in front of the page number. The numbering convention for the DS number is
“DSXXXXXA”, where “XXXXX” is the document number and “A” is the revision level of the
document.

For the most up-to-date information on development tools, see the MPLAB® IDE on-line help.
Select the Help menu, and then Topics to open a list of available on-line help files.

INTRODUCTION

The purpose of this document is to help users get up and running with Microchip’s
MPLAB C18 C compiler. Items discussed in this chapter are:

+ Document Layout

+ Conventions Used in this Guide

* Recommended Reading

* The Microchip Web Site

» Development Systems Customer Change Notification Service

» Customer Support

© 2004 Microchip Technology Inc. DS51295D-page 1
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DOCUMENT LAYOUT

This document describes how to install/uninstall MPLAB C18 and provides several
examples of writing C code for PICmicro® microcontroller applications. For a detailed
discussion about basic MPLAB IDE v6.xx functions, refer to the MPLAB IDE on-line

help file.
This document includes:

» Chapter 1: Overview — Defines system requirements and provides a brief
description of the installed programs and directories created by the installation

process.

» Chapter 2: Installation — Provides instructions on how to install the compiler onto

your system. Also provides uninstall instructions.

» Chapter 3: Examples of Use — uses a tutorial style to il
the MPLAB C18 C compiler. The examples use MPLAB

lustrate effective use of
IDE v6.xx with

PIC18F452, PIC18F4620 or PICX18F8720 as the selected device and MPLAB

SIM simulator as a debug tool. Some examples use the

additional tools, MPLAB

ICD 2 in-circuit debugger, PICDEM™ 2 Plus demo board and the PIC18Fxx20

64/80L TQFP demo board.

- Example 1 demonstrates how to set up and build a project; run, step and set

breakpoints in the example code; and debug the code

- Example 2 demonstrates the use of the MPLAB C18 peripheral libraries and
the C standard library, as well as the allocation of variables into program

memory.

- Example 3 demonstrates some of the differences between Extended and

Non-extended modes.

- Example 4 demonstrates the allocation of variables in access RAM.

- Example 5 demonstrates the use of interrupt service routines with
MPLAB C18 and provides an example of the use of the MPLAB C18

peripheral libraries.

- Example 6 demonstrates creating large data objects, the use of interrupt
service routines, and reading from and writing to the USART.

- Example 7 demonstrates the use of interrupt priority, reading from and writing
to EEDATA, and mixing interrupt driven and polling peripheral access.

» Glossary — A glossary of terms used in this guide.

* Index — Cross-reference listing of terms, features and sections of this document.

DS51295D-page 2
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CONVENTIONS USED IN THIS GUIDE

This manual uses the following documentation conventions:

DOCUMENTATION CONVENTIONS

Description

| Represents

Examples

Arial font:

Italic characters

Referenced books

MPLAB® IDE User’s Guide

Emphasized text

...is the only compiler...

Initial caps A window the Output window

A dialog the Settings dialog

A menu selection select Enable Programmer
Quotes A field name in a window or | “Save project before build”

dialog

Underlined, italic text with A menu path File>Save
right angle bracket
Bold characters A dialog button Click OK

A tab

Click the Power tab

Text in angle brackets < >

A key on the keyboard

Press <Enter>, <F1>

Courier font:

Plain Courier Sample source code #define START
Filenames autoexec.bat
File paths c:\mccl8\h
Keywords _asm, _endasm, static
Command-line options -Opa+, -Opa-
Bit values 0, 1

Italic Courier A variable argument file.o, where file can be

any valid filename

Obnnnn A binary number where nisa | 0b00100, 0b10
binary digit

0xnnnn A hexadecimal number where | OXFFFF, 0x007A

n is a hexadecimal digit

Square brackets [ ]

Optional arguments

mccl8 [options] file

[options]

Curly brackets and pipe
character: {| }

Choice of mutually exclusive
arguments; an OR selection

errorlevel {01}

Ellipses...

Replaces repeated text

var_name [,
var_name. . .]

Represents code supplied by
user

void main (void)

{
}

© 2004 Microchip Technology Inc.
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RECOMMENDED READING

For more information on included libraries and precompiled object files for the
compilers, the operation of MPLAB IDE and the use of other tools, the following are
recommended reading.

readme.c18

For the latest information on using MPLAB C18 C Compiler, read the readme.c18 file
(ASCII text) included with the software. This readme file contains update information
that may not be included in this document.

readme.xxx

For the latest information on other Microchip tools (MPLAB IDE, MPLINK™ linker, etc.),
read the associated readme files (ASCII text file) included with the software.

MPLAB® C18 C Compiler User’s Guide (DS51288)

Comprehensive guide that describes the operation and features of Microchip’s
MPLAB C18 C compiler for PIC18 devices.

MPLAB® C18 C Compiler Addendum (DS51518)

Lists the Configuration Bit Settings for the Microchip devices supported by the MPLAB
C18 C compiler.

MPLAB® IDE V6.XX Quick Start Guide (DS51281)

Describes how to set up the MPLAB IDE software and use it to create projects and
program devices.

MPASM™ User’s Guide with MPLINK™ Linker and MPLIB™ Librarian (DS33014)

Describes how to use the Microchip PICmicro MCU assembler (MPASM), linker
(MPLINK) and librarian (MPLIB).

PICmicro® 18C MCU Family Reference Manual (DS39500)

Focuses on the Enhanced MCU family of devices. The operation of the Enhanced MCU
family architecture and peripheral modules is explained but does not cover the
specifics of each device.

PIC18 Device Data Sheets and Application Notes

Data sheets describe the operation and electrical specifications of PIC18 devices.
Application notes describe how to use PIC18 devices.

To obtain any of the above listed documents, visit the Microchip web site
(www.microchip.com) to retrieve these documents in Adobe Acrobat (.pdf) format.

DS51295D-page 4
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THE MICROCHIP WEB SITE

Microchip provides online support via our WWW site at www.microchip.com. This web
site is used as a means to make files and information easily available to customers.
Accessible by using your favorite Internet browser, the web site contains the following
information:

* Product Support — Data sheets and errata, application notes and sample pro-
grams, design resources, user’s guides and hardware support documents, latest
software releases and archived software

* General Technical Support — Frequently Asked Questions (FAQ), technical
support requests, online discussion groups, Microchip consultant program
member listing

» Business of Microchip — Product selector and ordering guides, latest Microchip
press releases, listing of seminars and events, listings of Microchip sales offices,
distributors and factory representatives

DEVELOPMENT SYSTEMS CUSTOMER CHANGE NOTIFICATION SERVICE

Microchip’s customer notification service helps keep customers current on Microchip
products. Subscribers will receive e-mail notification whenever there are changes,
updates, revisions or errata related to a specified product family or development tool of
interest.

To register, access the Microchip web site at www.microchip.com, click on Customer
Change Notification and follow the registration instructions.

The Development Systems product group categories are:

» Compilers — The latest information on Microchip C compilers and other language
tools. These include the MPLAB C17, MPLAB C18 and MPLAB C30 C compilers;
MPASM™ and MPLAB ASM30 assemblers; MPLINK™ and MPLAB LINK30
object linkers; and MPLIB™ and MPLAB LIB30 object librarians.

+ Emulators — The latest information on Microchip in-circuit emulators.This
includes the MPLAB ICE 2000 and MPLAB ICE 4000.

* In-Circuit Debuggers — The latest information on the Microchip in-circuit
debugger, MPLAB ICD 2.

» MPLAB IDE - The latest information on Microchip MPLAB IDE, the Windows®
Integrated Development Environment for development systems tools. This list is
focused on the MPLAB IDE and MPLAB SIM simulators, MPLAB IDE Project
Manager and general editing and debugging features.

* Programmers — The latest information on Microchip programmers. These include
the MPLAB PM3 and PRO MATE® Il device programmers and the PICSTART®
Plus development programmer.

© 2004 Microchip Technology Inc. DS51295D-page 5
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CUSTOMER SUPPORT

Users of Microchip products can receive assistance through several channels:

+ Distributor or Representative

* Local Sales Office

+ Field Application Engineer (FAE)

» Technical Support

» Development Systems Information Line

Customers should contact their distributor, representative or field application engineer

(FAE) for support. Local sales offices are also available to help customers. A listing of
sales offices and locations is included in the back of this document.

Technical support is available through the web site at: http://support.microchip.com

In addition, there is a Development Systems Information Line which lists the latest ver-
sions of Microchip's development systems software products. This line also provides
information on how customers can receive currently available upgrade kits.

The Development Systems Information Line numbers are:
1-800-755-2345 — United States and most of Canada
1-480-792-7302 — Other International Locations

DS51295D-page 6
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Chapter 1. Overview

1.1 INTRODUCTION

This document is designed to get users started quickly using Microchip’s MPLAB C18
C compiler. PICmicro microcontroller applications can be easily developed using
MPLAB C18 with PIC18 PICmicro MCUs, MPLINK linker and MPLAB IDE. Please refer
to the MPLAB® C18 C Compiler User’s Guide (DS51288) for more details on the
features mentioned in this document. Information in this chapter includes:

» System Requirements

* Quick Directory Tour

» About the Language Tools

1.2 SYSTEM REQUIREMENTS

The minimum system requirements for using MPLAB C18 and the MPLINK linker are:

» 25 MB hard disk space (50 MB recommended)
« Intel Pentium® class PC running Microsoft® Windows® 9x, Windows 2000,
Windows ME, or Windows XP operating system

© 2004 Microchip Technology Inc. DS51295D-page 7
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1.3 QUICK DIRECTORY TOUR

The MPLAB C18 installation directory contains the readme file for the compiler
(readme. c18) and the readme file for the linker (readme . 1kr). In addition, a number
of subdirectories are also present. A detailed description of the subdirectories is shown
in Table 1-1.

TABLE 1-1: MPLAB C18 SUBDIRECTORY DESCRIPTIONS

Directory Description

bin Contains the executables for the compiler and linker. These are
described in more detail in the following section.

cpp Contains the source code for the MPLAB C18 C preprocessor. This
source code is provided for general interest.

doc Contains the MPLAB C18 electronic documentation. Refer to these
documents for questions regarding MPLAB C18.

example Contains sample applications to help users get started using
MPLAB C18, including the examples contained in this document.

h Contains the header files for the standard C library and the
processor-specific libraries for the supported PICmicro MCUs.

lib Contains the standard C library (c1ib.lib or clib e, 1lib), the

processor-specific libraries (p18xxxx.1lib or pl8xxxx_e.lib,
where xxxx is the specific device number) and the startup modules
(c018.0, c018 e.0,c0181i.0,c018i e.o, c01l8iz.o0,
c018iz_e.o).

1lkr Contains the linker script files.

mpasm Contains the command-line version of the MPASM assembler, the
assembly header files for the devices supported by MPLAB C18
(p1l8xxxx.inc) and the assembly header files used by the libraries.

src Contains the source code, in the form of C and assembly files, for the
standard C library, the processor-specific libraries and the startup
modules.

DS51295D-page 8 © 2004 Microchip Technology Inc.
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1.4 ABOUT THE LANGUAGE TOOLS

The bin and mpasm subdirectories of the MPLAB C18 compiler installation directory
contain the executables which comprise the MPLAB C18, MPASM assembler and the
MPLINK linker. A brief description of these programs is show in Table 1-2.

TABLE 1-2: MPLAB C18, MPASM ASSEMBLER AND MPLINK LINKER

EXECUTABLES
Executable Description
mccl8.exe This is the compiler shell. It takes as input a C file (i.e., file.c)
and invokes the Extended or Non-extended mode compiler
executable.
mccl8-extended.exe This is the Extended mode compiler executable. It is invoked by

the compiler shell when compiling for Extended mode. It
invokes the preprocessor cppl8 . exe to preprocess the C file
and then compiles the preprocessed output and generates a
COFF file (e.g., file. o) to be passed to the linker.

mccl8-traditional.exe | This is the Non-extended mode compiler executable. It is
invoked by the compiler shell when compiling for the
Non-extended mode. It invokes the preprocessor cppl8.exe
to preprocess the C file and then compiles the preprocessed
output and generates a COFF file (e.g., file.o) to be passed

to the linker.
cppl8.exe This is the C preprocessor.
mplink.exe This is the driver program for the linker. It takes as input a linker

script, object files and library files and passes these to
_mplink.exe. It then takes the output COFF file from
_mplink.exe and passes it to mp2cod.exe and
mp2hex. exe.

_mplink.exe This is the linker. It takes as input a linker script

(e.g., p18£f452.1kr), object files and library files and outputs a
COFF executable (e.g., file.out or file.cof). This COFF
file is the result of resolving unassigned addresses of data and
code of the input object files and referenced object files from
the libraries. _mplink.exe also optionally produces a map file
(e.g., £ile.map) that contains detailed information on the
allocation of data and code.

mp2cod.exe This is the COFF to COD file converter. The COD file is a
symbolic debugging file format which is used by the MPLAB
IDE v5.xx. mp2cod. exe takes as input the COFF file produced
by mplink.exe and outputs a COD file (e.g., file.cod). It
also creates a listing file (e.g., file.1lst) that displays the
correspondence between the original source code and machine
code.

mp2hex.exe This is the COFF to hex file converter. The hex file is a file
format readable by a PICmicro programmer, such as the
PICSTART Plus or the PRO MATE Il. mp2hex . exe takes as
input the COFF file produced by mplink.exe and outputs a
hex file (e.g., file.hex).

mplib.exe This is the librarian. It allows for the creation and management
of alibrary file (e.g., £ile.1lib) that acts as an archive for the
object files. Library files are useful for organizing object files
into reusable code repositories.

© 2004 Microchip Technology Inc. DS51295D-page 9
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TABLE 1-2:

MPLAB C18, MPASM ASSEMBLER AND MPLINK LINKER
EXECUTABLES (CONTINUED)

mpasm. exe

code.

This is the command-line assembler. It takes as input an
assembly source file (e.g., £ile.asm) and outputs either a
COFF file (e.g., £ile. o) or a hex file and COD file

(e.g., file.hex and file.cod). It also creates a listing file
(e.g., file.1lst) and an error file (e.g., file.err), which
contains any errors or warnings emitted during the assembly
process. Assembly source files may include assembly header
files (e.g, p18£452. inc), which also contain assembly source

More detailed information on the language tools, including their command-line usage,
can be found in the MPLAB® C18 C Compiler User’s Guide (DS51288) and the

MPASM™ User’s Guide with MPLINK™ and MPLIB™ (DS33014).

An example of the flow of execution of the language tools is illustrated in Figure 1-1.

FIGURE 1-1:

LANGUAGE TOOLS EXECUTION FLOW

Source
Files

Object
Files

Library and
Linker Script
Files

Output
Files

LEGEND

9

|| File

Input.asm Input1.c Input2.c
Q Program
N/ N/
mpasm.exe mcc18.exe mcc18.exe
( cpp18.exe ) cpp18.exe
\V4 N/
Input.o Input1.o Input3.o Input2.0
\/
lib1.lib script.lkr

F

mplink.exe

) Cmchod.exe) Cmthex.exe))

F 3

output.map

output.out

<

output.hex

output.Ist

output.cod
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Chapter 2. Installation

21 INTRODUCTION

This chapter will discuss in detail how to install MPLAB C18. Should it become
necessary to remove the software, uninstall directions are provided as well. Information
discussed in this chapter includes:

* Installing MPLAB C18
* Uninstalling MPLAB C18

2.2 INSTALLING MPLAB C18

To install MPLAB C18, run the setup program from the CD-ROM. If installing an MPLAB
C18 upgrade, run the upgrade setup program downloaded from the Microchip web site.
A series of dialogs will step through the setup process.

2.21 Welcome

A welcome screen displays the version number of MPLAB C18 that the setup program
will install, Figure 2-1.

FIGURE 2-1: MPLAB C18 WELCOME SCREEN

Thiz program will ingtall MPLAE C18 v XX on wour
computer. [F at ary time before the ingtallation
begins pou wizh to exit the zetup program, press
‘Cancel. Your computer will not have been
affected.
IMPORTANT: If pour computer iz running any version of
MPLAE IDE at thiz time and you wizh to update it to uze the
newly installed MPLAR C18 or MPLINE Linker, exit MPLAR IDE
nows befare continuing the setup program.

% ‘Wielcome ta the MPLAR C18 wx ¥ setup pragrarm.
_=

WARMIMG: Thiz program is protected by copyright law and
international treaties,

Unautharized repraduction ar distribution of this pragram, ar any
portion of i, may rezult in gevere civil and criminal penalties, and
will be prozecuted to the maximum extent pozsible under law,

Cancel

Click Next to continue.

© 2004 Microchip Technology Inc. DS51295D-page 11
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2.2.2 Readme File

The MPLAB C18 readme file is displayed. This file contains important information about
this release of MPLAB C18, such as known bugs, Figure 2-2.

FIGURE 2-2: MPLAB C18 README FILE

43 Read Me File

Release Motes for MPLAEB( C18, PICmicra 18CK% C compiler ﬂ
v X.XX

Date

Table of Contents

. Device Suppart List

. Installation

. Installation test

. What's hew in this release
MPLAE Configuration

. Supplied Libraries

. Linker zcripts

. Known Problems

. Contributars

10. How ta Contact Mizcrochip
11. Cugtomner Change Matification - Development Systemns

L0 00— O O e L O

[
Cancel l

After reviewing, click Next to continue.

223 Select Installation Directory

This step allows users to choose the directory where MPLAB C18 will be installed.
When installing MPLAB C18 for the first time, the default installation directory is
C:\mcc18, as shown in Figure 2-3.

If an upgrade is being installed, the setup program attempts to set the default
installation directory to the directory of the previous installation. The installation
directory for an upgrade must be the same directory of the previous installation or
upgrade.

Note: Files in the installation directory and its subdirectories may be overwritten
or removed during the installation process. To save any files, such as
modified linker scripts or library source code from a previous installation,
copy those files to a directory outside the installation directory before
continuing.

DS51295D-page 12 © 2004 Microchip Technology Inc.
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FIGURE 2-3: MPLAB C18 SELECT INSTALLATION DIRECTORY

MPLAE 18 wX ¥ will be inztalled in the following folder,

WA RMING: A file in thiz directon o one of itz subdirectonies
might be ovenwritten or remaoved by the setup program. [F pou
wizgh to keep any of these files, press 'Cancel' now and save
theze files to another directary. To chooze a different
installation directory, press Browse', If you are upgrading, the
inztallation directary must be the directany of the previous
installation or upgrade.

Fnstallatinn Diirectony

oo 8 Browse... |

< Back

Cahicel |

After specifying the directory, click Next.

224 Select Components

Choose the components to be installed by checking the appropriate box, Figure 2-4.

FIGURE 2-4: MPLAB C18 SELECT COMPONENTS
x|

I the list below, zelect the checkboxes for the companents
that you would like to have installed.  The disk zpace fieldz
reflect the requirements of the compaonents you have selected,
[+ Prograr files E914 k
¥ &zzembler files 1179k
[ Lirker script files B3k
[+ Standard headers 976 k
¥ Standard libraries 12048k
[ Docurnentation 4632 k
[+ Examples B3k
[+ Library source code 2212k
[~ Preprocessor source code 1834 k

Dizk Space Required: 23894 k

Disk Space Remaining: 4501111 k

< Back Cancel |

A detailed description of the available components is shown in Table 2-1.

© 2004 Microchip Technology Inc. DS51295D-page 13
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TABLE 2-1:

MPLAB C18 SOFTWARE COMPONENTS

Component

Description

Program files

These are the executables for the compiler and linker. Users should
install this component unless they are upgrading and wish to use the
executables from the previously installed version.

Assembler files

These include the command-line version of the MPASM assembler
(mpasm.exe), the assembly header files for the devices supported by
MPLAB C18 (p18xxxx.1inc) and the assembly header files used by
the libraries.

Linker script files

These files are used by the MPLINK linker. There is one file for each
supported PICmicro microcontroller. Each file provides a default
memory configuration for the processor and directs the linker in the
allocation of code and data in the processor’s memory.

These linker scripts differ from the linker scripts provided with the
MPLAB IDE in that these are specifically designed for use with MPLAB
C18. Since the MPLINK linker requires a linker script, users should
install this component unless they plan on creating their own linker
scripts.

Standard headers

These are the header files for the standard C library and the
processor-specific libraries. If users choose to install the standard
libraries, these will also be installed.

Standard libraries

This component contains the standard C library, the processor-specific
libraries, and the startup modules. See the MPLAB® C18 C Compiler
Libraries (DS51297) and the MPLAB® C18 C Compiler User’s Guide

(DS51288) for more information on the libraries and startup modules.

Since most typical programs use the libraries and a startup module, it
is recommended that users install this component.

Documentation

This is the electronic documentation for MPLAB C18.

Examples

These are sample applications to assist users in getting started with
MPLAB C18, including the examples described in this document.

Library source code

This is the source code for the standard C library and the
processor-specific libraries. Users should install this component if they
plan on rebuilding the libraries.

Preprocessor source

code

This is the source code for the preprocessor. It is provided for general
interest.

DS51295D-page 14
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225 Configuration Options

The next dialog screen allows users to select a particular set of MPLAB C18
configuration options for their system, Figure 2-5:

FIGURE 2-5: MPLAB C18 CONFIGURATION OPTIONS

It the list below, select the checkboxes for the desired
configuration options.

[~ Add MPLAR C18 to PATH ervironment variable

[~ Add MPASHM to PATH environment variable

[~ Add header file path to MCC_INCLUDE environment variable
[~ todify PATH and MCC_INCLUDE wvariables for all users

[ Update MPLAE IDE vE.xx to use this MPLAE C18
[~ Update MPLAB IDE vB.xx to use this MPLIME Linker

Cancel |

A detailed description of the available configuration options is shown in Table 2-2.
Select the components to be installed, then click Next.

© 2004 Microchip Technology Inc. DS51295D-page 15
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TABLE 2-2:

MPLAB C18 CONFIGURATION OPTIONS

Configuration

Description

Add MPLAB C18 to PATH
environment variable

This adds the path of the MPLAB C18 executable
(mcc18.exe) and the MPLINK linker executable
(mplink.exe) to the front of the PATH environment variable.
Doing this allows users to launch the newly installed version
of MPLAB C18 and the MPLINK linker at the command shell
prompt from any directory.

Add MPASM to PATH
environment variable

This adds the path of the MPASM executable (mpasm. exe)
to the front of the PATH environment variable. Doing this
allows users to launch the newly installed version of the
MPASM assembler at the command shell prompt from any
directory.

Add header file path to
MCC_INCLUDE environment
variable

This adds the path of the MPLAB C18 header file directory to
the front of the MCC_ INCLUDE environment variable. If this
variable does not exist, it is created. MCC_INCLUDE is a list of
semicolon-delimited directories that MPLAB C18 will search
for in a header file if it cannot find the file in the directory list
specified with the - T command-line option. Selecting this
configuration option means users will not have to use the -1
command-line option when including a standard header file.

Modify PATH and
MCC_INCLUDE variables for
all users

This option appears only if users are logged into a Windows
NT® or Windows 2000 computer as an administrator. Select-
ing this configuration will perform the modifications to these
variables as specified in the three previous options for all
users. Otherwise, only the current user’s variables will be
affected.

Update MPLAB IDE v6.xx to
use this MPLAB C18

This option appears only if the MPLAB IDE v6.xx is installed
on your system. Selecting this option configures the MPLAB
IDE v6.xx to use the newly installed MPLAB C18. This
includes using the MPLAB C18 library directory as the default
library path for MPLAB C18 projects in the MPLAB IDE v6.xx.

Update MPLAB IDE v6.xx to
use this MPLINK linker

This option appears only if the MPLAB IDE v6.xx is installed
on your system. Selecting this option configures the MPLAB
IDE v6.xx to use the newly installed MPLINK linker.

DS51295D-page 16
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2.2.6 Start Installation

The next dialog screen launches the installation, Figure 2-6. Once the Next button is
pressed, all files in the installation directory and its subdirectories will be overwritten or
removed.

FIGURE 2-6: MPLAB C18 START INSTALLATION

Installation x|

Y'ou are now ready to install MPLAB C18 v XX

Presz ‘Mest' to begin the installation or 'Back' to change the
installation information.

WARMIMG: Once the ingtallation beginz, any file in the
inztallation directary or one of its subdirectories might be
ovenwritten or removed. To exit the getup program ro without
averwniting or removing these files, press 'Cancel’.

Cahicel

227 Complete Installation

MPLAB C18 has now been successfully installed. In the “Installation Complete” dialog,
click Finish.

For MPLAB C18 to operate properly, it may be necessary to restart the computer. If the
“Restart Computer” dialog appears, select Yes to restart immediately, or No to restart
the computer at a later time.

2.3  UNINSTALLING MPLAB C18

To uninstall MPLAB C18, open the Windows control panel and launch “Add/Remove
Programs”. Select the MPLAB C18 installation in the list of programs and follow the
directions to remove the program. This will remove the MPLAB C18 directory and its
contents from the computer.

Note: If uninstalling an upgraded version of MPLAB C18, the entire installation
will be removed; MPLAB C18 cannot be “downgraded”.
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NOTES:
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MICROCHIP GETTING STARTED

Chapter 3. Examples of Use

3.1 INTRODUCTION

The following examples are intended to illustrate the effective use of MPLAB C18,
including how to create and build projects and how to step through programs.

These examples assume that MPLAB C18 and MPLAB IDE v6.xx are installed. Some
examples assume MPLAB ICD 2 is installed and connected to a PICDEM™ 2 Plus
demo board with a PIC18F452 device. Please refer to the PIC18FXX2 Data Sheet
(DS39564) for information regarding processor-specific items such as the special
function registers, instruction set and interrupt logic.

Examples presented in this chapter for using MPLAB C18 include:

Example 1 demonstrates how to set up and build a project; run, step and set
breakpoints in the example code; and debug the code.

Example 2 demonstrates the use of the MPLAB C18 peripheral libraries and the
C standard library, as well as the allocation of variables into program memory.

Example 3 demonstrates some of the differences between Extended and
Non-extended modes.

Example 4 demonstrates the allocation of variables in access RAM.

Example 5 demonstrates the use of interrupt service routines with MPLAB C18
and provides an example of the use of the MPLAB C18 peripheral libraries.
Example 6 demonstrates creating large data objects, the use of interrupt service
routines, and reading from and writing to the USART.

Example 7 demonstrates the use of interrupt priority, reading from and writing to
EEDATA, and mixing interrupt driven and polling peripheral access.

© 2004 Microchip Technology Inc. DS51295D-page 19
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3.2 EXAMPLE 1

This example is designed for use with the MPLAB IDE v6.xx, the MPLAB SIM simulator
and the PIC18F452 device. It shows how to set up an MPLAB C18 project in the
MPLAB IDE, build the project and step through the source code using the MPLAB SIM
simulator. Additionally, running the program using the MPLAB ICD 2 with the
PICDEM 2 Plus demo board is demonstrated. The example assumes that the directory
c:\mcc18 is the MPLAB C18 installation directory.

Here is the source code for the example:

#include <pl8cxxx.h> /* for TRISB and PORTB declarations */

/* Set configuration bits for use with ICD2 / PICDEM2 PLUS Demo Board:

* - set HS oscillator

* - disable watchdog timer

* - disable low voltage programming
*/

#pragma config OSC = HS
#pragma config WDT = OFF
#pragma config LVP OFF

int counter;
void main (void)

{

counter = 1;
TRISB = 0; /* configure PORTB for output */
while (counter <= 15)

{

PORTB = counter; /* display value of 'counter' on the LEDs */
counter++;

}

» TRISB and PORTB are special function registers on the PIC18F452 device. The
PORTB pins are connected to the LEDs on the PICDEM 2 demo board; the
TRISB pins configure the PORTB pins for input (1) or output (0).

» The configuration bits need to be set appropriately; this is done by utilizing the
#pragma config directive with settings for each configuration byte. This
includes specifying the oscillator used on the PICDEM 2 Plus demo board; in the
example, the crystal (0sCc=HS) is used. Additionally, MPLAB ICD 2 requires that
the Watchdog Timer and low-voltage programming be disabled (WDT=OFF and
LVP=0FF, respectively). The available configuration bit settings are listed in the
MPLAB® c18 C Compiler Addendum (DS51518).
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3.21 Setting Up the Project
Select Project>New to create a new project. Then enter the name and directory of the
project in the dialog that displays and click OK, Figure 3-1.

If the examples with MPLAB C18 were installed, then the
example\getting started\examplel subdirectory of the MPLAB C18
installation will already contain the source file for this example.

FIGURE 3-1: NEW PROJECT DIALOG

Mew Project

]

Froject Mame

|e>:am|:|le1

Froject Directon

|C: wmicc] Bheramplebgetting_startedbexamplel

Help ok Cancel

Note: The project name does not have to be the same as the directory name. I

The project tree will now be visible with a branch for each type of project file.

FIGURE 3-2: PROJECT TREE

B examplel.mew

- examplel.mcp
Source Files
Header Files
Object Files
Library Files
Linker Scripks

3.22 Select Target Processor

The target processor must be selected before anything else is done with the project.
This is accomplished by choosing Configure>Select Device.

FIGURE 3-3: SELECT DEVICE OPTION

M MPLAB IDE
File Edit WYiew Project Debugger Programmer ol Wwindow  Help

0O = ?

| .
Example1.mcw: ID Memary...

=-examplel.mcp
Source Files
Header Files
Object Files
Library Files
Linker Scripts

Settings...
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For this example, the PIC18F452 device will be used. Select the device and click OK.

FIGURE 3-4:

SELECT DEVICE DIALOG

Select Device

Device:

PIC18F4530 ppart
PIC18F458

PIC1BF4585 PLABICD 2
PIC18F4520 _PICKit1
PIC18F4B20

PIC18F6410 v

3

—Microchip Debugger Tool Support

@& MPLAB SIM @ MPLABICD 2
@ MPLAB SIM30

MPLAB ICE 2000 MPLAB ICE 4000
@ PCM1aHCT @ PuF1awcn
@ PCM18xHD

OK I Cancel Help

3.23 Select Project Settings

The MPLAB IDE needs to know which compiler and linker to use. To select MPLAB C18
and the MPLINK linker, first choose Project>Select Language Toolsuite.

FIGURE 3-5:

SELECT LANGUAGE TOOLSUITE OPTION

a5 MPLAB IDE
File Edit Wiew

& Debugger Programmer  Too Configure  Window Help

Bl Exampled.

=l examplel.r
Source Fi
Header F
Object Fi
Library Fi
Linker 5c

|||

Project wizard. ..

Mew. ..

Qpen. ..

Close

Set Active Projeck

Clean

Build all Ctrl+-F10
Make F10

Build Options. ..

Find in Project Files. ..

Save Project
Save Projeck As. ..

Add Files to Praject. ..
Remowe File From Project

Seleck Language Toolsuite. ..
Select Wersion-Contral Syskem, ..
Set Language Tool Locations. ..

|PIC1B8F452

| | |0x52d5 | A
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A dialog appears to select the language toolsuite. To use the language tools that
include MPLAB C18 and the MPLINK linker, select “Microchip C18 Toolsuite” as the

active toolsuite.

FIGURE 3-6: SELECT LANGUAGE TOOLSUITE DIALOG
Active Taolsuite: | Microchip £18 Toaksuite |
Fad

&R Systems Midrange

Toolsuite Contents -{14F Systems PICT8 Toolsuite

Microchip A5M30 Toolzuite

Microchip C17 Taolsuite
aE

MPLIME. Objec 18
MPLAB C18 C [hicrochip Ca0
Microchip MPASH Toolzuite
L 7 microE ngineering PicB azic Pro Toolsuite

aeation microE ngineering PicBasic Toolsuite b

|E:\F‘rogram Files\MPLAE IDE“MCHIP_T oolshmpasmwin.exe Browse. ..
Help 0K | Cancel |

Then, select “MPLINK Object Linker” and “MPLAB C18 C Compiler” and make sure
that the paths are to the newly installed versions of the executables, mplink . exe and
mccl8.exe, respectively. Click OK.

FIGURE 3-7: TOOLSUITE CONTENTS
K K
dclive Tolsutz: |Microchip 18 Teokuite | | | scive Tooksute: |Micrachip C18 Taokuie -
Taolsuite Contents Toolsuite Cantents

MPASM Assembler [mpasmuinexe
MPLI Liriker (mpii

i
MPLAB C18 C Compiler (mecl8.exe)

Lozation Location

|E:\mc01 Sbinmplink. sxe Browse... ‘C “mec] Bbinimec B eve Browsz..,
Help | e | Helo ‘ ok Cancel

Note: If the user chose to update the MPLAB IDE 6.xx to use the newly installed
compiler and linker in the MPLAB C18 setup program, these paths should
already be set up correctly.
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The next step is to set the command-line options for the compiler and linker. Choose
Project>Build Options>Project.

FIGURE 3-8: PROJECT BUILD OPTIONS
PLAE ID L]
File Edit View Debugger Programmer  Tools  Configure  Window  Help
J D Dﬁ. g | Project Wizard. .. b II b F} '{—}l {rp @
Mew, ..
Open...
Close

[ = examplel.r
- Saurce Fi

~Header F
- (biject Fi
-~ Library Fi
o Linker S

Sef Ackive Project

Quickbuild (no . asm File)

Al+F10

Clean
Build Al
Make

Cel+F10
Fio

Find in Praject Files. ..

Save Project

Save Project As..,

Add Files ko Praject...
Remove File From Project

Select Language Toolsuite. .,

Select Yersion-Contral System. ..
et Language Tool Locations. .
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Enter the paths of the header file and library subdirectories of the MPLAB C18
installation directory on the “General” tab as shown in Figure 3-9. The paths can be
typed or click on Browse to designate the path. MPLAB C18 will search for included
.h files in the specified header file directory. The MPLINK linker will search for object
and library files, including those specified in the linker script, in the library directory.
“Output Directory” is the final destination for files that result only from a complete build
of the project — the . cod, .cof and .hex files. Leave “Output Directory” blank; as a
result, the output file (examplel . cof) will be placed in the project directory.

“Intermediates Directory” is where the object files produced by the compiler will be
placed. Leave this entry blank as well; as a result, the object file (examplel . o) will be
placed in the same directory as the source file.

The MPLINK linker will search the directory specified in “Linker-Script Path” for linker
scripts. Since the location of the linker script will be specified when it is added to the
project tree, this entry can also be left blank for this example.

FIGURE 3-9: BUILD OPTIONS, GENERAL TAB

Build Options For Project “example1.mcp™

General | MPASM Assembler | MPLINK Linker | MPLAB 18|

Output Directary, $EINDIR):

| Browse...

Intermediates Directary, $TMPDIR]:

| Browse...

Azzembler Include Path, ${AINDIR]:

Include Path, $INCDIR]:

|E:\mcc:1 ik Browse...

Library Path, ${LIEDIR]:

| C:hmoc B4

Linker-Script Path, $LKRDIR]:

| Browse...
Help | Suite Defaultsl
oK | Cancel | Apply
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3.24 Select Compiler and Linker Settings

The various command-line options which are passed to the compiler and linker can be
set on the “MPLAB C18” and “MPLINK Linker” tabs, respectively, in the Build Options
window. For this example, the default command-line options for MPLAB C18 will be
accepted.

FIGURE 3-10: BUILD OPTIONS, MPLAB C18 TAB

Build Options For Project "example1.mcp™

General | MPASM Assembler | MPLINK Linker MPLAE C18 |

Categories: |GEnera\ ﬂ

Generate Command Line

[T Treat'char' as unsigned [ Enable integer pramations
Diagnostics level: Drefault storage class:
| Errars and warnings j |Auto j

Macro Definitions

Add..
Remove
Femave Al

I Restore Defaults

\}Du -0t -Ob- -Op- -0r- -0d- -Opa-

[ Use Alemate Settings

Ok | Cancel | Apply ‘

By default, when the MPLINK linker is run from the MPLAB IDE, it will not generate a
map (examplel .map) file. Change this by selecting “Generate map file” on the
“MPLINK Linker” tab. Click OK. The default settings will be used for the remainder of
the command-line options.

FIGURE 3-11: BUILD OPTIONS, MPLINK LINKER TAB

Build Options For Project “examplel.mcp™

General | MPASM Assembler MPLINK Linker | MPLAB C18

Categories; | 1Al Optians) -

Generate Command Line

HE-File Format

(& |NH=32

™ |MHxas [ Generate map file

™ INHEM I Suppress COD-file generation
" [Suppress)

Output Filename Root [ho leading directories, no extension]

] Restore Defaults

‘Jo”$[TAHGETBASE].cof"

[7 Use Alterate Settings

ak | Cancel Lpply
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3.2.5 Add Files to Project

The C source file must be added to the project. Click the right mouse button on “Source
Files” in the project window. Select “Add Files”.

FIGURE 3-12: SOURCE FILES, ADD FILES OPTION

B Examplel.mcw

- examplel.mcp

Hea Add Files. ..
bl Fiker
Librar R =

Linker Scripks

If c:\mccl8\example\getting started\examplel was chosen as the project
directory, the source file examplel . c already exists there. Browse to this directory and
select the file examplel. c. Click Open to add the file to the project.

FIGURE 3-13: ADD FILES DIALOG

Add Files to Project

Lok, jr: |._) examplel j IC:F -

[} ecamplel .

File narme: |e>:am|:|le1 =]

Files of type: |.-’-‘«II Source Files [*.asm;*.c) j Cancel

The source file should appear in the project tree.

FIGURE 3-14: SOURCE FILE IN PROJECT TREE

B Examplel.mcw

- examplel.mcp*
—I- Source Files
examplel.c
Header Files
Obiject Files
Library Files
Linker Scripks
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The header file is specified in the C source file; therefore no file needs to be added to
“Header Files” in the project tree. A header file may be added to “Header Files” for
convenient viewing of the file, but it is only required that the header file be included in
the C source code to build the project. The required startup module, standard library
and processor library are specified in the linker script, and so no file needs to be added
to “Object Files” or “Library Files” in the project tree. If there were other object files or
library files to link in the project, they would be added under these branches.

The MPLINK linker requires a linker script to be specified. Click the right mouse button
on “Linker Scripts” in the project window, and select Add Files.

FIGURE 3-15: LINKER SCRIPTS, ADD FILES OPTION

Cibject Files

Library Files

Linkgr ==t
Add Files...

B Examplel.mow

Filker

-I-examplel.mcp*
—|- Source Files
examplel.c
Header Files

Use the linker script 18£452 . 1kr in the 1kr subdirectory of the MPLAB C18
installation directory. This script is for the PIC18F452 device.

Click Open to add the file to the project tree.

FIGURE 3-16: LINKER SCRIPT, ADD FILES DIALOG

Add Files to Project

Look, jn: |_J lkr j L e -
15c242. ke 15658, kr 15F243. ke 15F442. ke :
18c252.lkr 18801 ke 18F2481 ke 18F4421 ke ;
180442, lkr 18801 ke 18F252 Ik 18F445 Ik ;
180452,y 150858, kr 182521, ke 1faddi, ke :
H1ace0tde =itz = 10058 18452y :
18c601 ke 18F242i ke 18F2581 ke 18F4521 ke ;
¢

File name: — |18f452 lkr

Files of type: |Linker Scripts [ lkr)

j Cancel

i,
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3.2.6 Build the Project

Select Project>Build All to compile and link the project. If there are any error or warning
messages, they will appear in the output window.

FIGURE 3-17: BUILD ALL OPTION

# MPLAB IDE

File Edit Wiew Debugger  Programmer Tools  Configure  Window Help

- Project Wizard. ..

Mew. ..
I Example 1. eI
Close
Set Active Project

=l examplel.r

Guickbuild {no asm File) Alt+F10

Clean

Build All Chrl+F10
Make

Build Cptions. ..

Find in Project Files. ..

Save Project

Save Project As...

Add Files to Project...
Remave File From Project

Select Language Toolsuite. ..
Select Yersion-Control System, ..
Set Language Tool Locations. ..

I [ [PIC1gF452 | | | | [0xgzds | /J

For this example, the output window should display no errors and a message stating
the output file was successfully built should be visible. If there were any errors, check
to see that the content of the source file matches the program text displayed at the
beginning of Section 3.2 “Example 1”.

FIGURE 3-18: OUTPUT FOR EXAMPLE 1

Qutput

Build ] Wersion Control i Find in Files !

2

Deleting intermediary files... done.

Executing: "Cymccl Sybinimeocl 8.exe” -p=18F452 "examplel.c" -fo="example1.0" i"Ciymccl §h" -Ou--0t--0
Executing: "Chmec] Byhinymplink.exe" A" ChmecT BYik" "Chrmoc] By k181452 Tkr

MPLINE 3 .60. Linker

Copyright {c) 2003 Hicrochip Technology Inc.

Errors .o

MP2COD 3.60, COFF to COD File Converter
Copyright (c) 2003 Microchip Technology Inc.
Errors o

MP2HEX 3 .60, COFF to HEX File Converter
Copyright (o) 2003 Microchip Technology Inc.
Errors o

Loaded Cimccl Biexamplelgetting_startediexamplelexamplel.cof i
BUILD SUCCEEDED: Fri Feb 06 10:56:27 2004
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3.27 Debugging with the MPLAB SIM Simulator

With the MPLAB SIM Simulator, breakpoints can be set in the source code to observe
the value of variables with a watch window. First, make sure that the MPLAB SIM
Simulator is selected as the debugging tool by selecting Debugger>Select
Tool>MPLAB SIM.

FIGURE 3-19: SELECT DEBUGGER, MPLAB SIM OPTION

. MPLAB IDE
Fil=  Edit

Views Praject

MPLAE ICD 2

MPLAB ICE 4000
MPLAB SIM - |0

MPLAE ICE 2000

= examplel.mcp
=1 Source Files
examplel.c
Header Files
Obiject Files
Library Files
= Linker Scripks
18452 lkr

Open the source file by double clicking on it in the project tree. In the source file, place
the cursor over the line where the breakpoint is desired to be set, and click the right
mouse button. Select “Set Breakpoint”.

FIGURE 3-20: SET BREAKPOINT OPTION

Bl C:wncclBlexampleigetting startediexamplelexamplel.c

L A
= * This is exawmple 1 from "Getting Started with MPLAE C15“. B
= L
<
= finclude <plScxxx_l= A% for TRISE and DPODRTE declaratiomns *7°
=
G int counter:
= woid main (woid)
= i
10 counter = 1;
11 TRIZSE = 0O A% configure FPORTE for output *7
1= while (counter == 15}
13 i
(1 4 PORTE = counter: e =
Set Breakpoink

af 'eoounter' om the LEDjLI
>

Breakpoints »

Fun to Cursor
Sek PC ak Cursaor

Delete

Text Mode »
Properties. ..
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The red dot in the gutter along the side of the source window indicates that the
breakpoint has been set and is enabled.

FIGURE 3-21:

BREAKPOINT ENABLED

i*

finclude <pl8cxxx_h=

* This iz example 1 from "Getting Started with MPLAE Clg8".
7

f* for TRISE and PORTE declarations */

int counter;
void nain (woid)

{

counter =
TRISE o;
while (counter <=
{

1:

f* conficure PORTE for output */
15}

c-:-unfEer; /* display walue of 'counter' on the LEDjﬂ
4

PORTE

To open a watch window on the variable counter, select View>Watch.

FIGURE 3-22:

VIEW, WATCH WINDOW OPTION

Project  Debugger Programmer  Tools  Configure  Window  Help

W Project

Bw B &

Oukpuk

-

Disassembly Listing
Hardware Stack
Program Mermory
Filz Registers
EEPRICM

LD Pixel

Special Function Registers
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Select counter from the menu next to Add Symbol, and click Add Symbol.

FIGURE 3-23:

WATCH WINDOW

h

Add SFR ”ADCDND vl Add S_l,lmbol"u:ounter ;I

=10] x|

Address

Symlool Name | Value I

[u]ul=p:N

counter aooo

watch 1 Watch 2| Watch 3] watch 4]

L

Click Run on the toolbar to run the program.

The program should halt just before the statement at the breakpoint is executed. The
green arrow in the gutter of the source window points to the next statement to be
executed. The watch window should show counter with a value of 1.

FIGURE 3-24: WATCH WINDOW COUNTER AT 1

Watch 1 Watch 2 | ||

= =10l %]
AddSFR |[RDCOND =  Add Syrbol|[counter
Lddress I Synbol Name I Value
o0gh counter oool

#Finclude <plicxxx.h> /* for TRISE and PORTE declarations +*/

int counter:
void main (void)

* This is example 1 from "Getting Started with MPLAE C15".
=

counter = 1;
TRISE = 0O: /% configure PORTE for output */
while [(counter <= 18]
i
PORTE = counter: /% diaplay waluse of 'counter' on the LEDs *,
counter++:
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Click Run again to continue the program. Execution should halt again at the
breakpoint. The watch window should show counter with a value of 2.

FIGURE 3-25: WATCH WINDOW COUNTER AT 2

I Vvatc =10l =l
Add SFR ”ADCDND Vl Add Symbn\l counter -

Address I Svmbol Name | Value I
oosn counter oooz

o Started with MPLALE C18".

watch1 | watch2 [ watch3[ watch 4]

#include <plScxxx.hs /% for TRISE and PORTE declarations */

int counter:
void mwain (void)
i
counter = 1;
TRISE = 0O: /7 configure PORTE for output #/
while (counter <= 15)
i
o PCORTE = counter: /* display value of 'counter' on the LEDs %,
counter++;

rat To step through the source code one statement at a time, use Step Into on
' the toolbar. As each statement executes, the green arrow in the gutter of
the source window moves to the next statement to be executed.

If the program is running, it can be halted by clicking Halt on the toolbar Il
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3.2.8 Map and Listing Files

The map file (examplel .map) and listing file (examplel.1lst) are present in the
project directory and may be opened by selecting File>Open, and then browsing to the
project directory. These files provide additional information which may be useful in
debugging, such as details of allocation of variables and the correspondence between
machine code and source code. For example, the map file shows that the variable
counter has been allocated to address 0x80 in data memory, and it was defined in
examplel.c as a non-static global variable, thus giving it external linkage (visibility to
other modules).

EXAMPLE 3-1: MAP FILE

Symbols - Sorted by Address

Name Address Location Storage File
counter 0x00008a data extern c:\mccl8\getting started\examplel\examplel.c
The listing file shows the machine code generated for each statement the main
function. For each instruction, its address, raw value and disassembly is displayed.
EXAMPLE 3-2: LISTING FILE
Address Value Disassembly Source
#include <pl8cxxx.h> /* for TRISB and PORTB declarations */
int counter;
void main (void)
0000e2 0e0l MOVLW 0x1 counter = 1;
0000e4 0100 MOVLB 0x0
0000e6 6f8a MOVWF 0x8a, 0x1
0000e8 6b8b CLRF 0x8b, 0x1
0000ea 6a93 CLRF 0x93, 0x0 TRISB = 0; /* configure PORTB for output */
0000ec 518b MOVF 0x8b, 0x0, 0x1 while (counter <= 15)
0000ee 0a00 XORLW 0x0
0000f0 aee8 BTFSS 0xe8,0x7,0x0
0000£f2 doo2 BRA oxfs8
0000f4 358b RLCF 0x8b, 0x0, 0x1
0000fe6 doos BRA 0x102
0000f8 OeOf MOVLW 0Oxf
0000fa 80d8 BSF 0xd8, 0x0, 0x0
0000fc 558a SUBFWB 0x8a, 0x0, 0x1
0000fe 0e00 MOVLW 0x0
000100 558b SUBFWB 0x8Db, 0x0, 0x1
000102 e306 BNC 0x110
00010e d7ee BRA Oxec
000104 c08a MOVFF 0x8a,0xf81 PORTB = counter; /* display 'counter' on the LEDs */
000106 ffg8l
000108 2b8a INCF 0x8a,0x1,0x1 counter++;
00010a 0e00 MOVLW 0x0
00010c 238b ADDWFC 0x8b, 0x1,0x1
1
000110 0012 RETURN 0x0 }
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3.29 Debugging with the MPLAB ICD 2

The MPLAB ICD 2 can be used to actually program the device and step through the

application. To do this, the project must be rebuilt with a linker script designed for use
with the MPLAB ICD 2. In the project window, click the right mouse button on the file

18f452.1kr under “Linker Scripts”, and click Remove.

FIGURE 3-26: LINKER SCRIPTS, REMOVE OPTION

B Examplel.mcw

| = examplel.mcp
-| Source Files
examplel.c
Header Files
Cibject Files
Library Files
—| Linker Scripts

Compile
Assemble

Edit

Remove

Add the linker script file 18£4521i . 1kr from the 1kr subdirectory of the MPLAB C18
installation directory under “Linker Scripts” in the project tree. This linker script allocates
memory for resources used by the MPLAB ICD 2. The ‘1’ in the file’s name indicates
this linker script is for use with the MPLAB ICD 2.

Rebuild the project by selecting Project>Build All.
To use the MPLAB ICD 2, select Debugger>Select Tool>MPLAB ICD 2.

FIGURE 3-27: SELECT DEBUGGER, MPLAB ICD 2 OPTION

w MPLAB IDE (=1[e3

. Configure  window Help

MPLAE ICE 4000
MPLAE SIM
MPLAE ICE 2000

| = examplel.mcp*®
—|- Source Filas
examplel.c
Header Files Reset

Ohject Files
Library Files
=I- Linker Scripts
18F4520, kr MPLAE ICD 2 Setup wWizard

Breakpoints., .,

Connect
Download ICDZ2 Operating System

Sektings
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To connect to the MPLAB ICD 2, choose Debugger>Connect. See the MPLAB ICD 2
documentation for information on how to configure the MPLAB ICD 2 connection

settings.
FIGURE 3-28: DEBUGGER, CONNECT OPTION
PLAB ID m
File Edit Wiew Project Programmer Tools  Configure  Window  Help
O | & | Secion ' E-2-1 A

(ST P

L [ I 2 L T

B Example!.mcw

examplel.mcp*
[=1- Source Files
examplel.c - -
Header Files Reset b
Cibject Files
Library Files
= Li!'lker acripks
18F452i. lkr MPLAB ICD 2 Setup Wizard

Breakpoints. .. Fz

Connect

Dovenload ICDE Operating Syskem

Settings

The output window should show that the MPLAB ICD 2 passed its self-test and is ready
to be programmed. If any errors occur, refer to documentation for the MPLAB ICD 2.

FIGURE 3-29: MPLAB ICD 2 OUTPUT
_|o| x|
Buid | Findin Files MPLABICD 2 |
Connecting to HPLAR ICD 2 -]
.. Connected
Setting Vdd =source to target
Target Device PIC13F45¢ found. revision = 0=x6
.. .Reading ICD Product ID
Funning ICD Self Test
.. .Pas=ed
. Doynload Operating Systen Succeseded
Funning ICD Self Te=st
.. .Pas=sed
HPLAE ICD 2 Ready
4| | 3
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To program the device, select Debugger>Program.

FIGURE 3-30: DEBUGGER, PROGRAM OPTION

 MPLAB IDE

File Edit Yiew Project NEEENsC® Frogrammer Configure  Window Help

@ | o m| et [ o mw®nee

! Clear Memory

Run

I'n Animate
Add SFR iAD CamM0 = Halt

Step Ower

Reset

EBreakpoints. ..
Advanced Breakpoints

Watch1  Watch 2 MPLAB ICD 2 Setup Wizard
| |, TRISE and PORTE declarations */

Zonneck

' fi PORTE £ tput T/
Download ICD2 Operating Syskem | semiiEuEe o euER

Settings
———————— T orar—cowmoerr——— display value of 'counter' on the LEDs *
v‘ countertt;
;

} -
4

Note: Programming the device requires reducing the program memory space
available to allow for MPLAB ICD 2 resources, disabling low voltage
programming and disabling the Watchdog Timer. If an MPLAB ICD 2
Warning dialog is received concerning any of these issues, simply click
OK to proceed.

The output window should show that the programming operation succeeded.

FIGURE 3-31: OUTPUT WINDOW, PROGRAMMING SUCCEEDED

=101 x|

Buld | Findin Files MPLAEICD 2 |

.. .Programming Debug Vector ﬂ
.. .Programming RSEBUG
.. .Programming Configuration Bits
Verifving. ..
.. .Program Hemory

. .Debug Ezxecutive

.Debug Vector

Verify Succesded

Config Memory

.. .Programming succesded
MFLAE ICD 2 Ready

1 | 3
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A breakpoint may be set in the source file as demonstrated for the MPLAB SIM
Simulator. When Run on the toolbar is clicked, the program halts immediately after the
statement where the breakpoint has been executed.

Note: This is different than the MPLAB SIM Simulator, which halts before the
statement where the breakpoint is executed. The green arrow points to
the next statement to be executed.

FIGURE 3-32: HALT AT BREAKPOINT
npletgetting_start ampleliexamplel.c =10] |
* This is example 1 from "Getting Jtarted with WMPLLE C15™. j
*

finclude <plScHxx. h> /% for TRISE and PORTE declarations */F

int counter:
roid main (void)
i
counter = 1;
TRISE = O: /% monfigure PORTE for output */
while [(counter <= 15)
{
FORETE = counter; f% display walue of 'counter' on the LEDs *,
counter++:

i@

'

P of

The PORTB register has been assigned the value of 1. The LEDs on the PICDEM 2 Plus
demo board, which are multiplexed with the PORTB pins, should display the binary
representation of 1.

Note: The J6 connection on the demo board must be jumpered in order to
connect the PORTB pins with the LEDs.

Each time Run on the toolbar is clicked, execution halts after the assignmentto PORTB
and the value on the LEDs should reflect the incriminated value of the counter.
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3.3 EXAMPLE 2

This example is designed for use with the MPLAB IDE v6.xx, the MPLAB ICD 2, the
PICDEM 2 Plus demo board and the PIC18F452 device. It demonstrates the use of the
MPLAB C18 peripheral libraries and the C standard library. It also demonstrates the
allocation of variables into program memory. The program cycles through a list of
strings, each representing a number from 0 to 15. Each string is converted into its
integer representation for display on the LEDs. The program pauses after displaying
each number to give the user an opportunity to observe the LEDs. For this program,
the J6 connection on the PICDEM 2 Plus demo board must be jumpered.

* MPLAB C18 places string literals in program memory; therefore, the rom keyword
is required in the declaration of the array string table. The const keyword
alone will not place the data in program memory; the rom keyword is required.
Since program memory in general cannot be modified without additional
specialized code, the const keyword is appropriate.

» The configuration bits need to be set appropriately; this is done by utilizing the
#pragma config directive with settings for each configuration byte. This
includes specifying the oscillator used on the PICDEM 2 Plus demo board; in the
example, the crystal (0sCc=HS) is used. Additionally, MPLAB ICD 2 requires that
the Watchdog Timer and low-voltage programming be disabled (WDT=0OFF and
LVP=0FF, respectively). Finally, since this example exclusively uses the MPLAB
ICD 2, background debugging should always be enabled (DEBUG=0N). The
available configuration bit settings are listed in the MPLAB® c18 C Compiler
Addendum (DS51518).

» The standard C library function atoi, which converts the string to an integer
representation, expects a character pointer located in data memory. However, as
the string literals are in program memory, they must be copied to data memory
first. The function strcpypgm2ram, which is an MPLAB C18 variant of strcpy,
does just that.

» The PORTB register, which is connected to the LEDs on the PICDEM 2 demo
board, and the TRISB register, which configures the PORTB pins for input or
output, are declared in the processor-specific header file p18£f452.h.

» MPLAB C18 provides several functions which provide delays of various lengths,
such as Delay10RTCYx used below. See the header file delays.h for more
details.
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This example can be built and linked in the MPLAB IDE v6.xx and used with the
MPLAB ICD 2 by following the steps in Example 1.

Note:

When compiling with the small code model, MPLAB C18 may emit a
warning about a type qualifier mismatch in an assignment with respect to
the call of strepypgm2ram. This happens because the second argument
passed to the function is a pointer to near program memory, while the
parameter’s type in the function prototype is a far program memory
pointer. Since the conversion from a near pointer to a far pointer is always
safe, this warning can be ignored. Alternatively, the warning may be
eliminated by compiling with the large code model (at the expense of
possibly a larger code image). To do this, choose “Build Options” and then
“Project” from the “Project” menu. Select “MPLAB C18” and choose

“Memory Model” from the drop-down menu. Finally, select the large code
model.

FIGURE 3-33: MEMORY MODEL OPTION

Build Options For Project “example 2.mcp™

Gieneral | MPASM Assembler | MPLINK Linker  MPLAB C18 |

Categaories: |Memor_-,l Model ﬂ

Generate Cammand L Mode

Optimization
Code Model

* Small code model (<= B4 bytes)
" Large code model [> G4K bytes)

Data Model

% Large data rmadel [all FaM banks)
" Small data model [accesz RAM anly]

Stack Model

* Single-bank model
™ Multi-bank model

I Restore D efaults

|-Du- -0t -Ob- -0p- Or- -0d- -Opa-

[ Usze Alternate Settings

akK | Cancel
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FIGURE 3-34: LARGE CODE MODEL OPTION

Build Options For Project “example 2.mcp™

General | MPASM Assembler | MPLINK Linker MPLAB C13 |

Categories: | Memary Madel j

Generate Command Line

Code Model

" Small code model [<= B4K bytes)
+ i arge code model [> B4F, bytest

[rata Model

+ Large data model [all RAM banks]
" Small data model [access RAM only]

Stack Model

+ Single-bank model
" Multi-bank model

|_ Festore Defaults

LmL-Dunub-ubunpnup-uduupa

[ Usze Alternate Settings

u].4 | Cancel Apply

#include <string.h> /* for 'strcpypgm2ram' *x/
#include <stdlib.hs> /* for 'atoi' */
#include <delays.h> /* for 'DelaylOKTCYx' */

#include <pl8cxxx.h> /* for 'PORTB' and 'TRISB' */

/* MPLAB C18 places string literals in program memory */
#define STRING TABLE SIZE 16
const rom char *string table[STRING TABLE SIZE] =

{ mom, wiw, w2m, w3w,
ngn, mgw, wgn owgw,
ngn, mgw, wignw, nmiim,
nigm, n13m, wign, w1sw

/* Set configuration bits for use with ICD2 / PICDEM2 PLUS Demo Board:

* - set HS oscillator
* - disable watchdog timer
* - disable low voltage programming
* - enable background debugging
*/
#pragma config OSC = HS
#pragma config WDT = OFF

#pragma config LVP = OFF
#pragma config DEBUG = ON

void main (void)

{
int index;
int integer;
char stringl[3];

PORTB
TRISB

0;
0; /* configure all PORTB pins for output */
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for (index = 0; index < STRING TABLE SIZE; index++)

{

/* copy the string from program memory to data memory for 'atoi' */
strcpypgm2ram (string, string table[index]) ;

/* get the number's integer representation from its string
* representation */
integer = atoi (string);

PORTB = integer; /* output the value to the LEDs */
DelaylOKTCYx (255); /* pause for a moment (255 * 10,000 cycles) */
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EXAMPLE 3

Beginning with v2.30, MPLAB C18 supports the PIC18 devices’ Extended mode, which
is targeted toward smaller code size for reentrant code; however, not all PIC18 devices
support the Extended mode. See the device data sheet for more details and other
implications.

This example is designed for use with the MPLAB IDE v6.xx, the MPLAB ICD 2, the
PICDEM 2 Plus demo board and the PIC18F4620 device. This example builds on
Example 2 and demonstrates some of the differences between Extended and
Non-extended mode.

3.41

This example will utilize the PIC18F4620 device as the target processor. Steps to select
the target processor can be found in Example 1.

Selecting the Processor

3.4.2 Utilizing the Extended Mode

MPLAB C18, by default, operates in Non-extended mode and it generates code that
will work on a device operating in Non-extended mode. This default behavior can be
changed with the command-line option —-extended. To make this change, choose
Project>Build Options>Project and click on the MPLAB C18 tab. Then, click in the
Extended Mode checkbox to enable Extended mode. Click OK.

FIGURE 3-35: PROJECT BUILD OPTIONS
PLAB ID L1
File Edit “iew Debugger  Programmer  Tools  Configure  Window  Help

Project Wizard...

D@

Mew, .
Open...
Close 3

[=-M3C18Exan

Sel Ackive Project

Build Options. ..

[ Source Fi

i - exam Cutickbuild {noc.asm File) Alk+F10
- Header F

- Cbject Fil  Clean

- Library Fi  Build Al Chrl+F10
“olinker 5o Make Fi

Project

Find in Project Files. ..

Save Project
Save Project As...

Add Files to Project...
Remaove File From Project

Select Language Toolsuite. .,
Select version-Contral Systen..,
Set Language Tool Locations. ..

PIC18F4620

Ox0420
d

© 2004 Microchip Technology Inc.

DS51295D-page 43



MPLAB® C18 C Compiler Getting Started

FIGURE 3-36: SETTINGS FOR EXTENDED MODE

General | MPASH Assembler | MPLINK Linker {MPLAE C13

Categories: | General =]

2]x]]

Generate Command Line

[ Treat 'char' as unsigred [ Enable integer promotions
Diagnostics level: Default storage class:
|Errc-r$ and warhings j |.-’-‘n.utc-

Macra Definitions

&dd

Remove

Mk,

Remawe &l

v Extended Mode
Restore Defaults

|-Du- Ot- -0b- -0p- -0r- -0d- -0pa- --extended

[ Usze Alemate Settings

Ok | Cancel | |

Up to four different types of linker scripts are distributed with the MPLAB C18 C
compiler for each processor. These linker scripts are different from those distributed
with the MPLAB IDE in that they automatically link in the compiler startup code and
libraries, as well as setting aside a stack area. The four linker scripts distributed for the
PIC18F4620 processor are:

18£4620.1kr For use with applications compiled in Non-extended mode.
18f4620i.1kr For use with applications compiled in Non-extended mode and being
debugged with the MPLAB ICD 2. The “i” represents that this linker
script allocates memory for resources used by the MPLAB ICD 2.
18£4620 e.lkr |Foruse with applications compiled in Extended mode.
18£4620i_e.lkr |Foruse with applications compiled in Extended mode and being
debugged with the MPLAB ICD 2. The “i” represents that this linker
script allocates memory for resources used by the MPLAB ICD 2.
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For this portion of the example, the 18£46201 e.lkr must be added to the project
files of the MPLAB IDE project. See Section 3.2 “Example 1” for information on how
to add files to a project.

Next, the EXTENDED18  predefined macro will be utilized to set up the
configuration words. The following should be added to the configuration settings
section of Example 2:

#ifdef _ EXTENDED18_
#pragma config XINST = ON
#else

#pragma config XINST = OFF
#endif

The above code will enable the Extended mode instructions when compiling in the
Extended mode, and disable the Extended mode instructions when compiling in
Non-extended mode.

343 Utilizing the Non-extended Mode

To change the above example from Extended mode to Non-extended mode, the
following steps must occur:

1. Disable Extended mode. Choose Project>Build Options>Project and click on the
MPLAB C18 tab. Then, if the Extended Mode checkbox has a check in it, clear
the checkbox by clicking on it. Click OK.

FIGURE 3-37: SETTINGS FOR NON-EXTENDED MODE

2]/
General | MPASH Assembler] MPLINE. Linker

Categories: | General j

Generate Command Line

[ Treat 'char' as unsigned [ Enable integer promotions
Diagnostics level: Default storage class:
|Errors and warrings j |.t’-‘«uto

tacro Definitions

dd
Remawve

Remove &l

[ Extended Mode
Reztare Defaultz

[ Usze Alemate Sethings

U,

Ok | Caticel | |

2. Remove the Extended mode, MPLAB ICD 2 linker script (18£46201 e.lkr)
from the MPLAB IDE project.

3. Addthe Non-extended mode, MPLAB ICD 2 linker script (18£46201i . 1kr)to the
MPLAB IDE project.
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3.5 EXAMPLE 4

This example is designed for use with the MPLAB IDE v6.xx, the MPLAB SIM simulator
and the PIC18F452 device. It demonstrates the allocation of variables in access RAM.
For each value from 0 to 99, the program finds the square root of the value with the
fractional part truncated. It then squares this root to obtain the greatest perfect square
less than or equal to the original value.

» The square root function is implemented as a table in program memory. This has
several advantages. If the table were in data memory, it would need to be copied
from program memory to data memory at program initialization. Locating the table
in program memory also saves data memory space. Finally, the code associated
with calculating the square root at runtime may occupy more program memory
than a table when the domain of the function is small.

» Data located in access RAM does not require the BSR register to be loaded, thus
resulting in fewer instructions. The variables root and square are located in an
access RAM section named MY ACS DATA. The type qualifier near must be
used to ensure that MPLAB C18 knows bank selection is not required for these
objects.

This example can be built and linked in the MPLAB IDE v6.xx and used with the MPLAB
SIM simulator by following the steps in Example 1.

MPLAB C18, by default, assumes all statically allocated data objects, unless explicitly
specified with the near type qualifier, reside in banked (non-access) RAM. This default
behavior can be changed with the command-line option -0a+. To make this change,
choose Project>Build Options>Project.

FIGURE 3-38: PROJECT BUILD OPTIONS

. MPLAB IDE

File Edit Wiew NE{i==# Debugget Programmer Tools  Configure  Window  Help

Project Wizard. ..

Mew...

Open...

Close

Set Active Project

Clean
Build Al ChrHF10
Make F10
exampled.c

Find in Project Files. ..

Save Project

Save Project &s...

Add Files ta Project...
Remove File From Project

Select Language Toolsuite, .,
Select Yersion-Contral System. ..
Set Language Tool Locations..,

EMPLAB D2 (PIC18F452 poilx1243a |
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Select the tab labeled “MPLAB C18” and choose “Memory Model” from the drop-down

menu.

FIGURE 3-39:

MEMORY MODEL OPTION

Build Options For Project “example4.mcp™

General | MPASM Assembler | MPLINK Linker MPLAB C18 |

Cateqgories: |General

7|

General
Generate Cammand Liprpssspry s

Optimization

[ Treat 'char' as unzaned T

Diagnostics level:

ERable mteger promotions

Default storage class:

j |Autc-

|Errc-rs and warnitgs

M acro Definitions

=

~

Add..

Remowe

Remave all

Restare Defaults

j Ik

|-Du- -0t- -0b- -Op- -0r- -0d- -Opa-

[ Use Albermate Settings

e

Cancel
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Finally, select the small data model to tell MPLAB C18 that statically allocated data
objects without an explicit near or far qualifier are located in access RAM. See the
MPLAB® C18 C Compiler User’s Guide (DS51288) for details on access and banked

(non-access) RAM. Click OK.

FIGURE 3-40:

SMALL DATA MODEL OPTION

Build Options For Project “example4.mcp®

General | MPASM Assembler | MPLINK Linker MPLAE C18 |

Categanies |M'3""'°'5J todel

Generate Commatd Line

Code Model

Data Model

* Small code model [<= B4K bytes)
" Large code model [ B4K bytes)

" Large data model [all RAM banks)

=

i+ Small data model [access BAM anly}

Stack Model

* Single-bark rmodel
" Multi-bank madel

-

Restare Defaults

|-Da -Ou- -Ot- -0b- -Op- -0r- -0d- -Opa-

[ Usze Altermate Settings

o]

Cancel Apply
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#include <pl8f452.h> /* for 'PRODL' declaration and 'ACCESS' macro */

/*

* Locate the read-only table in program memory at address 0x1000.

* 'romdata' is used for data, and 'code' is used for instructions.
*/

#pragma romdata ROOT_ TABLE = 0x1000
#define TABLE SIZE 100
const rom unsigned char roots|[TABLE SIZE] =

{o, 1, 1,1, 2, 2,2, 2, 2, 3,
3, 3, 3, 3, 3, 3, 4, 4, 4, 4,
4, 4, 4, 4, 4, 5, 5, 5, 5, 5,
5,5, 5,5, 5,5, 6, 6, 6, 6,
6, 6, 6, 6, 6, 6, 6, 6, 6, 7,
7, 7, 7, 7, 7, 7, 7, 1. 1, 7,
7, 7, 7, 7, 8, 8, 8, 8, 8, 8,
8, 8, 8, 8, 8, 8, 8, 8, 8, 8,
8, 9, 9, 9, 9, 9, 9, 9, 9, 9,
9, 9, 9,9, 9,9, 9,9, 9, 9};

/*

* Data in access ram does not require banking.
*  When compiled with -Oa, these pragmas and the near qualifier may
* be removed.
*/
#pragma udata access MY ACS DATA
near unsigned char root, square;
#pragma udata /* continue allocating static data in non-access ram */

/-k
* Returns the truncated root of the value.
*/

unsigned char get root (int val)

{
}

return roots[val];

void main (void)

{

static int wval;

for (val = 0; val < TABLE SIZE; val++)
{
/* 'square' holds the greatest perfect square less than or
* equal to 'val' */
square = get_root (val);

}

Note: When compiling this example with static data in access RAM by default,
the udata pragmas surrounding the declarations of root and square may
be removed, as well as the near type qualifier.
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3.6

EXAMPLE 5

This example is designed for use with the MPLAB ICD 2, the PICDEM 2 Plus demo
board, the MPLAB IDE v6.xx and the PIC18F452 device. It demonstrates the use of
interrupt service routines with MPLAB C18. It also provides an example of the use of
the MPLAB C18 peripheral libraries. For this program, the J6 jumper on the demo
board must be removed in order to disconnect the PORTB pins from the LEDs.

This program generates the Piezo buzzer of the PICDEM 2 Plus demo board. The
user may disable the buzzer by pressing the S3 button. The buzzer may be
reactivated by pressing the button again.

The S3 button is connected to the INTO pin, which is associated with the INTO
external interrupt. This interrupt is a high priority interrupt, and so will always
trigger a branch to program memory address 0x8. Located at this address is the
interrupt service routine (high ISR), which branches to the procedure that turns
the buzzer either off or on.

The configuration bits need to be set appropriately; this is done by utilizing the
#pragma config directive with settings for each configuration byte. This
includes specifying the oscillator used on the PICDEM 2 Plus demo board; in the
example, the crystal (0SC=HS) is used. Additionally, MPLAB ICD 2 requires that
the Watchdog Timer and low-voltage programming be disabled (WDT=OFF and
LVP=0FF, respectively). Finally, since this example exclusively uses the MPLAB
ICD 2, background debugging should always be enabled (DEBUG=0N). The
available configuration bit settings are listed in the MPLAB® C18 C Compiler
Addendum (DS51518).

toggle buzzer is declared as a high priority interrupt routine. This means the
WREG, BSR and STATUS registers will be saved and restored via their shadow
registers without explicit instructions upon interrupt routine entry and exit.
Additionally, upon return, the GIEH bit in the INTCON register will be set, which
was cleared when the interrupt was triggered. Refer to the PIC18FXX2 Data
Sheet (DS39564) for details on interrupt logic.

This example can be built and linked in the MPLAB IDE v6.xx and used with the MPLAB
ICD 2 by following the steps in Example 1.

#include <pl8f452.h> /* for the special function register declarations */

#include <portb.h>

/* for the RBO/INTO interrupt */

/* Set configuration bits for use with ICD2 / PICDEM2 PLUS Demo Board:

* - get HS oscillator

disable watchdog timer
disable low voltage programming
enable background debugging

* -

* -

* -

*/
#pragma config OSC = HS
#pragma config WDT = OFF
#pragma config LVP = OFF
#pragma config DEBUG = ON
/-k

void toggle buzzer

#pragma code HIGH INTERRUPT VECTOR =

* For high interrupts, control is transferred to address 0x8.
*/

(void) ; /* prototype needed for 'goto' below */

0x8

void high ISR (void)

DS51295D-page 50

© 2004 Microchip Technology Inc.



Examples of Use

_asm
goto toggle buzzer
_endasm

}

#pragma code /* allow the linker to locate the remaining code */

/*
* If the buzzer is on, turn it off. If it is off, turn it on.
*/
#pragma interrupt toggle buzzer
void toggle buzzer (void)
{
CCP1CON = ~CCP1CON & 0xOF; /* turn the buzzer off or on */
INTCONbits.INTOIF = 0; /* clear flag to avoid another interrupt */

void EnableHighInterrupts (void)

{

RCONbits.IPEN = 1; /* enable interrupt priority levels */
INTCONbits.GIEH = 1; /* enable all high priority interrupts */

void InitializeBuzzer (void)

{

T2CON = 0x05; /* postscale 1:1, Timer2 ON, prescaler 4 */
TRISCbits.TRISC2 = 0; /* configure the CCP1 module for the buzzer */
PR2 = 0x80; /* initialize the PWM period */

CCPR1L = 0x80; /* initialize the PWM duty cycle */

void SoundBuzzer (void)
{
CCP1CON = O0xOF; /* turn the buzzer on */
while (1) ; /* wait for the S3 button to be pressed */

void main (void)

{
EnableHighInterrupts ( );
InitializeBuzzer ( );

OpenRBOINT (PORTB_CHANGE INT ON & /* enable the RBO/INTO interrupt */
PORTB_PULLUPS ON & /* configure the RBO pin for input */
FALLING EDGE_ INT) ; /* trigger interrupt upon S3
button depression */

SoundBuzzer ( );
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3.7 EXAMPLE 6

This example is designed for use with the MPLAB ICD2, the PICDEM 2 Plus demo
board, the MPLAB IDE v6.xx, and the PIC18F452 device. The key concepts of this
example are: creating large data objects, the use of interrupt service routines, and
reading from and writing to USART.

» This program will prompt the user (via HyperTerminal) to enter a digit between 0
and 9. Upon receiving a character from the USART, the program will then either
output a string from an array of data or if the character received is not between 0
and 9, output an error string.

* The USART receive is set up as a high-priority interrupt, which will trigger a
branch to the program memory address 0x08. At this address is located the
high-priority interrupt vector (rx_int), which branches to the function that ser-
vices the USART receive interrupt (rx_handler). This function will determine
whether the key pressed is between 0 and 9 and output the correct string based
on the data received. In addition, it will light the LEDs to display the value of the
character received.

This example can be built and linked in the MPLAB IDE v6.xx and used with the MPLAB
ICD2 by following the steps in Example 1. A HyperTerminal properties file has been
provided for your convenience.

By default, MPLAB C18 assumes that an object will not cross a bank boundary. An
object that is larger than 256 bytes can be created, but the following steps are required
to create a multi-bank object:

1. The object must be allocated into its own section using the #pragma idata or
#pragma udata directive.
#pragma udata buffer scn
static char buffer[0x180] ;
#pragma udata
2. A pointer to the object to use for access to that object must be created.
char * buf ptr = &buffer[0];

// examples of use
buf ptr([5] = 10;
if (buf ptr[275] > 127)

3. A new region that spans multiple banks must be created in the linker script.
Linker script before modification:
DATABANK NAME=gpr2 START=0x200 END=0x2FF
DATABANK NAME=gpr3 START=0x300 END=0x3FF

Linker script after modification:
DATABANK NAME=big START=0x200 END=0x37F PROTECTED
DATABANK NAME=gpr3 START=0x380 END=0x3FF

4. The object’s section (created in step #1) must be assigned into the new region
(created in step #3). Add a SECTION directive to the linker script.
SECTION NAME=buffer scn RAM=big
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#include <pl8f452.h>
#include <usart.h>

/* Set configuration bits for use with ICD2 / PICDEM2 PLUS Demo Board:

* - set HS oscillator
* - disable watchdog timer
* - disable low voltage programming
* - enable background debugging
*/
#pragma config OSC = HS
#pragma config WDT = OFF

#pragma config LVP = OFF
#pragma config DEBUG = ON

void rx handler (void) ;

#define BUF_SIZE 25

/*
* Step #1 - The data is allocated into its own section.
*/

#pragma idata bigdata

char data([11] [BUF_SIZE+1] = {

"String #0\n\r" },
"String #1\n\r" }
"String #2\n\r" }
"String #3\n\r" }
"String #4\n\r" }
"String #5\n\r" },
"String #6\n\r" }
"String #7\n\r" }
"String #8\n\r" }
"String #9\n\r" }
"Invalid key (0-9 only)\n\r" }

}i

#pragma idata

#pragma code rx interrupt = 0x8
void rx_int (void)

{

_asm goto rx handler _endasm

}

#pragma code

#pragma interrupt rx handler
void rx handler (void)

{

unsigned char c;

/* Get the character received from the USART */
¢ = ReadUSART () ;
if (¢ >= '0' && Cc <= '9")
{
c -= '0';
/* Display value received on LEDs */
PORTB = c;
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Step #2 - This example did not need an additional
pointer to access the large memory because of the
multi-dimension array.

Display the string located at the array offset
of the character received

/
PutsUSART (datalc]);

}

else

{
/

* %k kX X X X F

Step #2 - This example did not need an additional
pointer to access the large memory because of the
multi-dimension array.

I . I I

Invalid character received from USART.
Display error string.

*

*/
PutsUSART (datal[10]);

/* Display value received on LEDs */
PORTB = c;

}

/* Clear the interrupt flag */
PIR1bits.RCIF = 0;

}

void main (void)

{
/* Configure all PORTB pins for output */
TRISB = 0;

/*
* Open the USART configured as
* 8N1, 2400 baud, in polled mode
*/
OpenUSART (USART TX INT OFF &
USART_RX_INT ON &
USART ASYNCH MODE &
USART EIGHT_BIT &
USART_CONT_RX &
USART BRGH_HIGH, 103);

/* Display a prompt to the USART */
putrsUSART (
(const far rom char *)"\n\rEnter a digit 0-9!\n\r");

/* Enable interrupt priority */
RCONbits.IPEN = 1;

/* Make receive interrupt high priority */
IPR1bits.RCIP = 1;

/* Enable all high priority interrupts */
INTCONbits.GIEH = 1;

/* Loop forever */
while (1)

1
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Linker Script:

// This file was originally 18f452i.lkr as distributed with MPLAB C18.

// Modified as follows:

// - combine banks 4 and 5 into PROTECTED DATABANK "largebank"

// - moved stack to gpr3

// - Assign the "bigdata" SECTION into the new "largebank" region

LIBPATH

FILES c018i.o0o
FILES clib.1lib
FILES pl8f452.1ib

CODEPAGE NAME=vectors
CODEPAGE NAME=page
CODEPAGE NAME=debug
CODEPAGE NAME=idlocs
CODEPAGE NAME=config
CODEPAGE NAME=devid
CODEPAGE NAME=eedata

ACCESSBANK NAME=accessram

DATABANK  NAME=gpr0
DATABANK  NAME=gprl
DATABANK  NAME=gpr2
DATABANK  NAME=gpr3

// Step #3

// This is

DATABANK NAME=largebank
DATABANK NAME=dbgspr

ACCESSBANK NAME=accesssfr

SECTION NAME=CONFIG

START=0x0
START=0x2A
START=0x7DCO
START=0x200000
START=0x300000
START=0x3FFFFE
START=0xF00000

START=0x0
START=0x80
START=0x100
START=0x200
START=0x300

START=0x400
START=0x5F4
START=0xF80

ROM=config

END=0x29
END=0x7DBF
END=0x7FFF
END=0x200007
END=0x30000D
END=0x3FFFFF
END=0xXFOOOFF

END=0x7F
END=0xFF
END=0x1FF
END=0x2FF
END=0x3FF

- Create a new region in the linker script
the databank that will contain the large memory object

END=0x5F3
END=0x5FF
END=0xXFFF

PROTECTED

PROTECTED
PROTECTED
PROTECTED
PROTECTED
PROTECTED

PROTECTED
PROTECTED
PROTECTED

// Step #4 - Assign the large memory object's section into the new region

SECTION NAME=bigdata

STACK SIZE=0x100 RAM=gpr3

RAM=1largebank
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3.8 EXAMPLE7

This example is designed for use with the MPLAB ICD2, the PIC18Fxx20 64/80L TQFP
demo board, the MPLAB IDE v6.xx, and the PIC18F8720 device. The key concepts of
this example are: the use of interrupt priority, reading from and writing to EEDATA, and
mixing interrupt driven and polling peripheral access.

This program will rotate the LEDs of the PIC18Fxx20 64/80L TQFP demo board,
which are attached to PORTD. When the lower left button is pushed, the direction
that the LEDs are rotating will reverse. The POT can be used to control the speed
of the rotating LEDs.

Analog Channel 0 (an0) for the ADC is attached to the POT. Peripheral access to
the ADC is done through polling in the main function. The ADC conversion results
in setting the current _ad_value variable, which is used in the TMR2 interrupt to
determine if the LEDs should be updated.

The TMR2 interrupt is a low-priority interrupt, which will trigger a branch to the
program memory address 0x18. At this address is located the low-priority
interrupt vector (Low_vector), which branches to the function that services the
TMR2 interrupt (tmr2). This function will determine whether it is time to update the
LEDs, and if it is, will rotate the LED to the next LED based on the direction.

External interrupt O (RB0) is attached to the lower left button. This button when
pushed will trigger a high-priority interrupt, which will trigger a branch to the pro-
gram memory address 0x08. At this address is located the high-priority interrupt
vector (high_vector), which branches to the function that services the external
interrupt (but ton). This function will change the direction that the LEDs are
rotating and write the updated direction variable to EEDATA.

Master clear (MCLR) is attached to the upper right button.

The first step that the main function will perform is to read the direction
variable from EEDATA.

This example can be built and linked in the MPLAB IDE v6.xx and used with the MPLAB
ICD2 by following the steps in Example 1.

The following steps are required to read EEDATA data from C code:

1.

2.

Ensure EEPGD is clear for EEDATA access
EECON1lbits.EEPGD = 0;

Store the address to EEADR

EEADR = addr,

Trigger a read by setting the RD bit
EECON1bits.RD = 1;

Read the result from EEDATA register

my variable = EEDATA,
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The following steps are required to write EEDATA data from C code:

1. Ensure EEPGD is clear for EEDATA access
EECON1lbits.EEPGD = O;

2. Ensure WREN is set to enable EEDATA writes
EECON1lbits.WREN = 1;

3. Write address to EEADR
EEADR = addr;

4. Set EEDATA to the value to write
EEDATA = value,

5. Write 0x55 to EECON2
EECON2 = 0x55;

6. Write 0xAA to EECON2
EECON2 = OxAA,

7. Initiate write cycle by setting the WRr bit
EECONlbits.WR = 1;

8. Wait for the EEIF flag to be set
while (!PIR2bits.EEIF)

9. Clear the EEIF flag
PIR2bits.EEIF = 0;

Note: Interrupts must be disabled during steps 5-7.

#include <pl8cxxx.h>
#include <delays.h>

/* Set up the configuration bits */
#pragma config OSC = HS, 0OSCS = OFF
#pragma config PWRT = OFF

#pragma config BOR = OFF

#pragma config WDT = OFF

#pragma config CCP2MUX = OFF
#pragma config LVP = OFF

void tmr2 (void) ;
void button (void) ;

#pragma code high vector section=0x8
void
high vector (void)

_asm
GOTO button
__endasm

}

#pragma code

#pragma code low_vector_ section=0x18
void
low vector (void)

{
_asm

GOTO tmr2
_endasm

}

#pragma code
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volatile unsigned current_ad value;
int count = 0;
volatile enum { DIR LEFT =

#pragma interruptlow tmr2
void
tmr2

{

}

(void)

0, DIR RIGHT } direction;

/* clear the timer interrupt flag */
PIR1bits.TMR2IF = O0;

/*

* if we have reached the repeat count,

*
*/

if
r
els
c

/*

* Based on the direction,

*/
if

{

}

els

{

}

update the LEDs

(count++ < current ad value)
eturn;

e

ount = 0;

(direction == DIR LEFT)
_asm

RLNCF PORTD, 1, O
__endasm
e

_asm
RRNCF PORTD, 1, O
_endasm

#pragma interrupt button
void
button (void)

{

dir

* % ok %k *

*

ection = !direction;

Store the new direction in EEDATA.

Note that since we are already

in the high priority interrupt,
not need to explicitly enable/disable

interrupts around the write cycle

*/
EECON1bits.EEPGD = 0; /*
EECON1bits.WREN = 1; /*
EEADR = 0; /*
EEDATA = direction; /*
EECON2 = 0x55; /*
EECON2 = Oxaa; /*
EECON1lbits.WR = 1; /*
while (!PIR2bits.EEIF) /*

7

PIR2bits.EEIF = 0; /*

WRITE
WRITE
WRITE
WRITE
WRITE
WRITE
WRITE
WRITE

WRITE

step
step
step
step
step
step
step
step

step

we do

#1
#2
#3
#4
#5
#6
#7
#8

#9

rotate the LEDs

*/
*/
*/

*/
*/
*/
*/

*/
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/* clear the interrupt flag */
INTCONbits.INTOIF = O;

void
main (void)
{

/*

* The first thing to do is to read
* the start direction from data EEPROM.

*/
EECON1lbits.EEPGD = O; /* READ
EEADR = 0; /* READ
EECON1bits.RD = 1; /* READ
direction = EEDATA; /* READ
/*

* Make all bits on the Port D
* pbits for the LEDs

*/
TRISD = 0;

/* Make PORTA RAO input,

TRISAbits.TRISAO = 1;

step #1
step #2
step #3
step #4

output

/* PORTB RBO input for the button */
TRISBbits.TRISBO = 1;

/* Reset Port D.

PORTD = 1;

/* Enable interrupt priority */

RCONbits.IPEN = 1;

*/
*/
*/
*/

Set just one bit to on.

for the A/D converter */

*/

/* Clear the peripheral interrupt flags */

PIR1 = 0;

/* Enable the timer interrupt */
PIElbits.TMR2IE = 1;

IPR1bits.TMR2IP

/*

* Set the button on RBO to trigger an

* interrupt. It is always high priority

*/

0;

INTCONbits.INTOIE = 1;

/* Configure the ADC, most of this is the
* default settings:
* Fosc/32
* ANO Analog,
*
* Internal voltage references
*
* An equivalent setup using the ADC
* library would be:
* OpenADC (ADC_FOSC 32 &
* ADC_LEFT JUST &
* ADC_1ANA,
* ADC_CHO &

AN1-15 Digital Channel zero Interrupt disabled
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ADC_INT OFF &
ADC_VREFPLUS VDD &
* ADC_VREFMINUS_VSS ) ;
*/

/* FOSC/32 clock select */
ADCON2bits.ADCSO = 1;
ADCON2bits.ADCS1 = 1;
ADCON2bits.ADCS2 = 1;
ADCON2bits.ADCS2 = 1;
/* AN0-15, VREF */
ADCON1 = 0b00001110;

/* Enable interrupts */
INTCONbits.GIEH = 1;
INTCONbits.GIEL = 1;

/* Turn on the ADC */
ADCONObits.ADON = 1;

/* Enable the timer */
T2CONbits.TMR20ON = 1;

/* Start the ADC conversion */
while (1)

{

Delayl00TCYx (2);

/* Give the ADC time to get ready.

/* start the ADC conversion */

ADCONObits.GO = 1;
while (ADCONObits.GO) ;
current ad value = ADRES;
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Glossary

A

Absolute Section
A section with a fixed address that cannot be changed by the linker.
Access Memory

Special general purpose registers on the PIC18 PICmicro microcontrollers that allow
access regardless of the setting of the Bank Select Register (BSR).

Address

The code that identifies where a piece of information is stored in memory.
Anonymous Structure

An unnamed object.

ANSI

American National Standards Institute

Assembler

A language tool that translates assembly source code into machine code.
Assembly

A symbolic language that describes the binary machine code in a readable form.
Assigned Section

A section that has been assigned to a target memory block in the linker command file.
Asynchronously

Multiple events that do not occur at the same time. This is generally used to refer to
interrupts that may occur at any time during processor execution.

B

Binary

The base two numbering system that uses the digits 0-1. The right-most digit counts
ones, the next counts multiples of 2, then 22 =4, etc.

C

Central Processing Unit

The part of a device that is responsible for fetching the correct instruction for execution,
decoding that instruction and then executing that instruction. When necessary, it works
in conjunction with the Arithmetic Logic Unit (ALU) to complete the execution of the
instruction. It controls the program memory address bus, the data memory address bus
and accesses to the stack.

Compiler

A program that translates a source file written in a high-level language into machine
code.
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Conditional Compilation

The act of compiling a program fragment only if a certain constant expression, specified
by a preprocessor directive, is true.

CPU
Central Processing Unit

E

endianness

The ordering of bytes in a multi-byte object.

Error File

A file containing the diagnostics generated by the MPLAB C18.
Extended Mode

In Extended mode, the compiler will utilize the extended instructions (i.e., ADDFSR,
ADDULNK, CALLW, MOVSF, MOVSS, PUSHL, SUBFSR and SUBULNK) and the indexed
with literal offset addressing.

F

Fatal Error
An error that will halt compilation immediately. No further messages will be produced.
Frame Pointer

A pointer that references the location on the stack that separates the stack-based
arguments from the stack-based local variables.

Free-standing

An implementation that accepts any strictly conforming program that does not use
complex types and in which the use of the features specified in the library clause
(ANSI ‘89 standard clause 7) are confined to the contents of the standard headers
<float.h>, <is0646.h>, <limits.h>, <stdarg.h>, <stdbool.h>,
<stddef .h> and <stdint.h>.

H

Hexadecimal

The base 16 numbering system that uses the digits 0-9 plus the letters A-F (or a-f).
The digits A-F represent decimal values of 10 to 15. The right-most digit counts ones,
the next counts multiples of 16, then 162 = 256, etc.

High-level Language

A language for writing programs that is further removed from the processor than
assembly.

ICD

In-Circuit Debugger

ICE

In-Circuit Emulator

IDE

Integrated Development Environment
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IEEE
Institute of Electrical and Electronics Engineers
Interrupt

A signal to the CPU that suspends the execution of a running application and transfers
control to an ISR so that the event may be processed. Upon completion of the ISR,
normal execution of the application resumes.

Interrupt Service Routine

A function that handles an interrupt.

ISO

International Organization for Standardization
ISR

Interrupt Service Routine

L

Latency

The time between when an event occurs and the response to it.

Librarian

A program that creates and manipulates libraries.

Library

A collection of relocatable object modules.

Linker

A program that combines object files and libraries to create executable code.
Little Endian

Within a given object, the least significant byte is stored at lower addresses.

Memory Model
A description that specifies the size of pointers that point to program memory.
Microcontroller

A highly integrated chip that contains a CPU, RAM, some form of ROM, I/O ports and
timers.

MPASM Assembler

Microchip Technology's relocatable macro assembler for PICmicro microcontroller
families.

MPLIB Object Librarian

Microchip Technology's librarian for PICmicro microcontroller families.
MPLINK Object Linker

Microchip Technology's linker for PICmicro microcontroller families.

N
Non-extended Mode

In Non-extended mode, the compiler will not utilize the extended instructions nor the
indexed with literal offset addressing.
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o)

Object File

A file containing object code. It may be immediately executable or it may require linking
with other object code files (e.g., libraries), to produce a complete executable program.

Object Code
The machine code generated by an assembler or compiler.
Octal

The base 8 number system that only uses the digits 0-7. The right-most digit counts
ones, the next digit counts multiples of 8, then 8% = 64, etc.

P

Pragma
A directive that has meaning to a specific compiler.

R

RAM

Random Access Memory

Random Access Memory

A memory device in which information can be accessed in any order.
Read Only Memory

Memory hardware that allows fast access to permanently stored data but prevents
addition to or modification of the data.

ROM

Read Only Memory

Recursive

Self-referential (e.g., a function that calls itself).
Reentrant

A function that may have multiple, simultaneously active instances. This may happen
due to either direct or indirect recursion or through execution during interrupt
processing.

Relocatable

An object whose address has not been assigned to a fixed memory location.
Run-time Model

Set of assumptions under which the compiler operates.

S

Section

A portion of an application located at a specific address of memory.
Section Attribute

A characteristic ascribed to a section (e.g., an access section).
Special Function Register

Registers that control 1/0 processor functions, 1/0 status, timers or other modes or
peripherals.
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Storage Class

Determines the lifetime of the memory associated with the identified object.
Storage Qualifier

Indicates special properties of the objects being declared (e.g., const).

\'

Vector

The memory locations that an application will jump to when either a reset or interrupt
occurs.
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NOTES:
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